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1 Installation – Kvaser CanKing Distributions 
Before you can use Kvaser CanKing, you must download and install the Kvaser Drivers. Kvaser 
CanKing can be downloaded from our homepage: Here you can find all Kvaser downloadable 
software and drivers. 

https://kvaser.com/download/ 

Instructions for how to install the Kvaser drivers are included in the respective software and not 
covered by this guide. 

1.1 Kvaser CanKing, Windows x64 
Distributed as a Windows installer, an .exe file. 

Prerequisites: 

• Kvaser Drivers for Windows 

1.2 Kvaser CanKing, Linux for Intel x64 
Distributed as a Debian package, a .deb file. 

Prerequisites: 

• Kvaser Drivers for Linux 
• Kvaser SDK for Linux 

CanKing does not work with SocketCAN, you must use the Kvaser Drivers. 

1.3 Kvaser CanKing, Linux for ARM 64 
Distributed as a Debian package, a .deb file. 

Prerequisites: 

• Kvaser Drivers for Linux 
• Kvaser SDK for Linux 

CanKing does not work with SocketCAN, you must use the Kvaser Drivers.  

https://kvaser.com/download/
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2 CanKing Layout 

 

 

When starting CanKing (without opening a project file), you will see the default layout. 

There are four major areas: 

• Control area 
• Setup area 
• Measurement area 
• Log and Terminal area 
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3 CanKing Control Area 

 

3.1.1  Start / Stop measurement 
A measurement can be started by clicking on the start button at the top-left corner of the main 
window, or by selecting 'More->Measurement->Start' from the main menu, or by pressing 'F9'. 

A measurement can be stopped by clicking on the stop button at the top-left corner of the main 
window, or by selecting 'More->Measurement->Stop' from the main menu, or by pressing 'F12'. 

 

When a measurement is started then: 

• All enabled CAN Channels try to connect to their hardware interfaces. 
• All enabled Traffic Generators start sending data. 
• All enabled CAN Message Loggers with start triggers set to Start Measurement begin 

logging. 

When a measurement is stopped then: 

• All connected CAN Channels disconnect from their hardware interfaces. 
• All started Traffic Generators stops sending data. 
• All started CAN Message Loggers stops logging. 
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3.1.2  New Project 
A new CanKing project can be created by clicking on the 'New' button in the main window's title 
bar, or by selecting 'More->File->New' from the main menu, or by pressing 'Ctrl + N'. 

3.1.3  Open Project 
A CanKing project can be opened by clicking on the 'Open' button in the main window's title bar, 
or by selecting 'More->File->Open' from the main menu, or by pressing 'Ctrl + O'. 

3.1.4  Save Project 
The current CanKing project can be saved by clicking on the 'Save' button in the main window's 
title bar, or by selecting 'More->File->Save' from the main menu, or by pressing 'Ctrl + S'. 

3.1.5  More… 
Save As The current CanKing project can be saved to new file by selecting  

'More->File->Save As' from the main menu, or by pressing 'Ctrl + Shift + 
S'. 

Zoom In The user interface can be zoomed in by selecting 
'More->View->Zoom In' from the main menu, or by pressing 'Ctrl + +'. 

Zoom Out The user interface can be zoomed out by selecting 
'More->View->Zoom Out' from the main menu, or by pressing 'Ctrl + -'. 

Reset Zoom  The user interface's zoom factor can be reset by selecting  
'More->View->Reset Zoom' from the main menu, or by pressing 'Ctrl + 
0'. 

Toggle Full Screen  The main window can enter Full Screen mode selecting  
'More->View->Toggle Full Screen Mode' from the main menu, or by 
pressing 'F11'. 
The main window can leave Full Screen mode selecting  
'More->View->Toggle Full Screen Mode' from the main menu, or by 
pressing 'F11', or by clicking on the 'Exit Full Screen' button in the top-
right corner of the main window. 

3.1.6  Settings 
The Edit Settings dialog can be opened by selecting 'More->Settings', or by clicking on the 
'Settings' button in the main window's title bar, or by pressing 'Ctrl + ,'. 

The following fields exist in the Edit Settings dialog: 

Theme A select box to select the user interface theme. Possible themes are 
'Light Mode' and 'Dark Mode'. 

Language A select box to select the language to be used in the user interface. 



Kvaser CanKing User Guide   6(44) 

 Kvaser AB, Mölndal, Sweden – www.kvaser.com 

Numeric Base A select box to select the default numeric base for message identifiers 
and message data. Possible values are 'Hexadecimal' and 'Decimal'. 

Closing Action A select box to select what action to perform when the application is 
closing. Possible values are 'Prompt for action', 'Stop measurement 
and clear setup' and 'Keep any measurement running'. 

3.1.7  Dark mode/Light mode 
Possible themes are 'Light Mode' and 'Dark Mode' 

3.1.8  Toggle tools panel 
The 'Toggle tools panel' button either shows or hides the lower tools panel where you find the 
Log and Terminal views. 
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4 CanKing Measurement Area 

 

4.1  Open Measurement Setup 
The Measurement Setup view is opened by clicking on the 'Measurement Setup' button in the 
navigation bar. 

4.2  Source – Add a new data source 
Available data sources are: 

CAN Channel A new CAN Channel node can be added by clicking on the '+ Source' 
button and selecting 'CAN Channel'. 

All Connected CAN Channels 
All CAN channels that are connected to the computer can be added at 
the same time by clicking on the '+ Source' button and selecting 'All 
Connected CAN Channels'. 

Traffic Generator A new Traffic Generator node can be added by clicking on the '+ Source' 
button and selecting 'Traffic Generator'. 
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4.3 CAN Channel 

 

4.3.1 Add CAN Channel 
Adding a CAN channel can be done by clicking on Source and selecting CAN Channel. 

4.3.2 Remove CAN Channel 
The CAN Channel node can be removed from the measurement setup by right-clicking on the 
CAN Channel node and selecting 'Remove' from the context menu or by clicking on the 
'Remove' button inside the node. 

4.3.3 Disable/Enable CAN Channel 
The CAN Channel node can be disabled/enabled by right-clicking on the CAN Channel node 
and selecting 'Disable'/'Enable' from the context menu or by clicking on the 'Disable/Enable' 
toggle button inside the node. 

4.3.4 Set Bus On/Off for CAN Channel 
The CAN Channel can be set to 'Bus On' or 'Bus Off' by clicking on the 'Bus On/Off' toggle button 
inside the node. 
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4.3.5 Edit CAN Channel 

 

The Edit CAN Channel Configuration dialog can be opened by right-clicking on the CAN Channel 
node and selecting 'Edit Configuration...' from the context menu or by clicking on the 'Edit' 
button inside the node. 

 

4.3.6 CAN Channel Configuration 

 

The following fields and functions exist in the Edit CAN Channel Configuration dialog: 

Name A name that will be used in CanKing to reference this node. 

Interface A select box to point out which hardware interface and channel to be 
used. 
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S/N A read-only field displaying the serial number of the selected hardware 
interface. 

Locked to S/N A check box that locks the CAN Channel to the interface with the 
specified serial number instead of locking to the CANlib channel 
number. Selecting this option will guarantee that the CAN Channel 
always uses the same hardware interface. 

Rescan A button that triggers a rescan of the computer for added hardware 
interfaces. 

CAN Mode A select box to select CAN mode. Possible values are 'CAN', 'CAN FD' 
and 'CAN FD NONISO'. 
 
When 'CAN Mode' is set to 'CAN FD' or 'CAN FD NONISO' then the 'Bus 
Speed' will be replaced with 'Bus Speed Arbitration Phase' and a 'Bus 
Speed Data Phase' will be added. 

Access Mode A select box to select access mode to be used when initializing the 
interface. Possible values are 'Init Access', 'No Init Access' and 
'Exclusive Access'. 
  
'Init Access' will try to initialize the interface by setting the selected bus 
speed. If any other application is connected to the same interface with 
init access, then this will fail. 
 
'No Init Access' will prevent CanKing from setting the interface's bus 
speed. 
 
'Exclusive Access' will make sure that only CanKing is connected to the 
interface. 

Silent Mode A check box that makes the interface act in silent mode. This setting is 
disabled if the interface doesn't support silent mode. 

Bus Speed A select box with a predefined list of bus speeds. 

SJW A select box with possible SJW values for the selected bus speed. 

Bit Timing A button that opens a table with all possible bit timing combinations for 
the selected bit rate. 
 
This table can be used to select bit timings that aren't listed in the 'Bus 
Speed' select box. 
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4.4 Traffic Generator 

 

4.4.1 Adding Traffic Generator 
Adding a Traffic Generator can be done by clicking on Source and selecting Traffic Generator. 

The Edit Traffic Generator Configuration dialog can be opened by right-clicking on the Traffic 
Generator node and selecting 'Edit Configuration...' from the context menu or by clicking on the 
'Edit' button inside the node. 

4.4.2 Remove Traffic Generator 
The Traffic Generator node can be removed from the measurement setup by right-clicking on 
the Traffic Generator node and selecting 'Remove' from the context menu or by clicking on the 
'Remove' button inside the node. 

4.4.3 Disable/Enable Traffic Generator 
The Traffic Generator node can be disabled/enabled by right-clicking on the Traffic Generator 
node and selecting 'Disable'/'Enable' from the context menu or by clicking on the 
'Disable/Enable' toggle button inside the node. 

4.4.4 Traffic Generator Configuration 
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The following fields and functions exist in the Edit Traffic Generator Configuration dialog: 

Field Description 

Name A name that will be used in CanKing to reference this node. 

Channel A select box to select which CAN Channel to send out CAN messages 
on. 

CAN Identifier A set of fields to control the CAN identifier(s) to be used in the CAN 
messages. 

Constant Identifier The same identifier is used for every message. 

Random Identifier Identifier to use is picked by taking a random identifier from a specified 
range. 
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Scan identifier Identifier to use is picked from a specified range. 

Frame Definition A set of fields to control what kind of CAN frame to send out and what 
data it should contain. 

Frame type Possible frame types are: 
• CAN 
• CAN FD 
• ERRORFRAME. 

For a classic CAN frame it's possible to select 
• Remote Request Frame 
• Single Shot 

For a CAN FD frame it's possible to select: 
• BRS - bit rate switch 
• Single Shot 

Frame data Defined by selecting message data length and by editing the message 
raw data by entering the value of each byte. Both the message data 
length and the message raw data can be randomized. 

Transmission Interval A set of fields to control the transmission interval. 

Constant interval The same interval is used between each transmission. 

Random interval Interval to use is picked by taking a random interval from a specified 
range. 

Scan interval Interval to use is picked from a specified range. 

Number of Messages Specifies a fixed number of messages to be sent out or an unlimited 
number of messages. 

Burst Size A set of fields to control the burst size, i.e. the number of messages to 
be sent out at every sample point. 

Constant burst size The same number of messages are sent out at every sample point. 

Random burst size Burst size to use is picked by taking a random value from a specified 
range. 
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4.5 Data Processors 

 
Available data processors are: 

• CAN Message Filter 
• CAN Databases 

4.5.1 Re-organize data processor nodes 
Data processors can be re-organized in the measurement setup by changing the connections 
between the nodes. This can be done either by drag & drop or by editing the configuration of a 
receiving node and changing its sources list. 

4.5.2 Data Processors - CAN Message Filter 
4.5.2.1 Add CAN Message Filter 
A new CAN Message Filter node can be added by clicking on a '+' button on any of the nodes in 
the measurement setup and selecting 'CAN Message Filter'. The new CAN Message Filter node 
will be connected to the node that was clicked on. 
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4.5.2.2 Remove CAN Message Filter 
The CAN Message Filter node can be removed from the measurement setup by right-clicking on 
the CAN Message Filter node and selecting 'Remove' from the context menu or by clicking on 
the 'Remove' button inside the node. 

4.5.2.3 Disable/Enable CAN Message Filter 
The CAN Message Filter node can be disabled/enabled by right-clicking on the CAN Message 
Filter node and selecting 'Disable'/'Enable' from the context menu or by clicking on the 
'Disable/Enable' toggle button inside the node. 

4.5.3 CAN Message Filter Features 

 

The Edit CAN Message Filter Configuration dialog can be opened by right-clicking on the CAN 
Message Filter node and selecting 'Edit Configuration...' from the context menu or by clicking on 
the 'Edit' button inside the node. 

The following fields and functions exist in the Edit CAN Message Filter dialog: 

Name A name that will be used in CanKing to reference this node. 

Filter Type A radio button group with one button for 'Pass Filter' and one button for 
'Block Filter' 

Std CAN Identifiers A text field to list with standard (11-bit) CAN identifiers that should be 
filtered out.  
The identifiers can be listed individually as a comma separated list or in 
ranges, for example the string 1,2,3,6-10 will filter out identifiers 1, 2, 3 
and 6 to 10. 

Ext CAN Identifiers A text field to list which extended (29-bit) CAN identifiers that should be 
filtered out. The identifiers can be listed individually as a comma 
separated list or in ranges, for example the string 1,2,3,6-10 will filter 
out identifiers 1, 2, 3 and 6 to 10. 

Sources A check box list with all measurement setup nodes that can be 
connected as sources to this node. 

  



Kvaser CanKing User Guide   16(44) 

 Kvaser AB, Mölndal, Sweden – www.kvaser.com 

4.5.4 Data Processors - CAN Databases 
4.5.4.1.1 Add CAN Databases 
A new CAN Databases node can be added by clicking on a '+' button on any of the nodes in the 
measurement setup and selecting 'CAN Databases'. The new CAN Databases node will be 
connected to the node that was clicked on. 

4.5.4.2 Remove CAN Databases 
The CAN Databases node can be removed from the measurement setup by right-clicking on the 
CAN Databases node and selecting 'Remove' from the context menu or by clicking on the 
'Remove' button inside the node. 

4.5.4.3 Disable/Enable CAN Databases 
The CAN Databases node can be disabled/enabled by right-clicking on the CAN Databases 
node and selecting 'Disable'/'Enable' from the context menu or by clicking on the 
'Disable/Enable' toggle button inside the node. 

4.5.5 CAN Databases Features 

 

The Edit CAN Databases Configuration dialog can be opened by right-clicking on the CAN 
Databases node and selecting 'Edit Configuration...' from the context menu or by clicking on the 
'Edit' button inside the node. 

The following fields and functions exist in the Edit CAN Databases dialog: 

Field Description 

Name A name that will be used in CanKing to reference this node. 

DBC Files An 'Add' button to browse and add database files and a list of selected 
files. 

Sources A check box list with all measurement setup nodes that can be 
connected as sources to this node. 
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4.6 Data Targets 

 

Available data targets are: 

UI Streams  A read-only node that cannot be added or removed. It is always present 
and represents a data stream to the user interface in CanKing. 

CAN Output Channel A read-only node that cannot be added or removed. It represents the 
output buffer of the 'CAN Channel' data source node. Every 'CAN 
Channel' data source node that isn't configured to be in silent mode will 
have a corresponding 'CAN Output Channel'.  

CAN Message Logger  A Logger node that can be added to one or more data streams. 

4.6.1 CAN Message Logger 
4.6.1.1.1 Add CAN Message Logger 
A new CAN Message Logger node can be added by clicking on the '+ Target' button and 
selecting 'CAN Message Logger'. 
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4.6.1.1.2 Remove CAN Message Logger 
The CAN Message Logger node can be removed from the measurement setup by right-clicking 
on the CAN Message Logger node and selecting 'Remove' from the context menu or by clicking 
on the 'Remove' button inside the node. 

4.6.1.2 Disable/Enable CAN Message Logger 
The CAN Message Logger node can be disabled/enabled by right-clicking on the CAN Message 
Logger node and selecting 'Disable'/'Enable' from the context menu or by clicking on the 
'Disable/Enable' toggle button inside the node. 

4.6.1.3 CAN Message Logger Configuration 
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The Edit CAN Message Logger Configuration dialog can be opened by right-clicking on the CAN 
Message Logger node and selecting 'Edit Configuration...' from the context menu or by clicking 
on the 'Edit' button inside the node. 

The following fields and functions exist in the Edit CAN Message Logger dialog: 

Name A name that will be used in CanKing to reference this node. 

File Format A select box to select what file format the log file should use. 

File Name A text field and a 'Browse...' button to enter full path to the log file to be 
created. 

File Name Action A radio button group to decide what should happen if a file already exists with 
the specified file name. 
Possible options are: 
•  Append next available index to the file name. 
•  Append timestamp to the file name. 
•  Overwrite any existing file. 

Start Trigger A radio button group to decide what detected event should start the logger. 
Possible triggers are: 
•  Start Measurement: The logger starts when a new measurement is started. 
•  Timer: The logger starts at a specified time after the measurement was 
started. 
•  Message: The logger starts when a message with a specified CAN identifier 
has been received. 
•  Signal Value: The logger starts when a signal value expression has been 
fulfilled. 

Stop Trigger A radio button group to decide what detected event should stop the logger. 
Possible triggers are: 
•  Stop Measurement: The logger stops when the measurement is stopped. 
•  Timer: The logger stops at a specified time after the logger was started. 
•  Message: The logger stops when a message with a specified CAN identifier 
has been received. 
•  Signal Value: The logger stops when a signal value expression has been 
fulfilled. 

Sources A check box list with all measurement setup nodes that can be connected as 
sources to this node.  
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5 Workspaces 

 

5.1   Open Workspace Setup 
The Workspace Setup view is opened by clicking on the Workspace Setup button in the 
navigation bar. 
 

 

There are four Workspaces available: 

• CAN Bus Statistics 
• CAN Periodic Send 
• CAN Send 
• CAN Trace 
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5.2 Edit Workspace 
The workspace can be set in 'Edit Mode' by selecting the 'Edit' toggle button in the top-right 
corner of the Workspaces view. 

In edit mode it's possible to: 

• Rename the workspace. 
• Add/Remove panes inside the workspace. 
• Change type of view displayed in the panes. 

'Edit Mode' is closed by deselecting the 'Edit' toggle button in the top-right corner of the 
Workspaces view. 

5.2.1 Add Workspace 
A new workspace can be added by clicking on the '+' button displayed next to the right of the 
last workspace tab. 

5.2.2 Remove Workspace 
A workspace can be removed by hovering the mouse over the workspace name and clicking on 
the 'x' button that appears, or by pressing 'Ctrl + F4' to remove the currently selected 
workspace. 

5.2.3 Rename Workspace 
A workspace can be renamed by double-clicking on the workspace name. 
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5.3 CAN Bus Statistics Features 

 

The CAN Channel to present statistics for is selected in a CAN Channel select box. 

The following bus statistics are displayed: 

• Bus load, the bus load in percentage. 
• Rx Messages, number of received messages since the counter was cleared and the 

average number of received messages per second. 
• Tx Messages, number of transmitted messages since the counter was cleared and the 

average number of transmitted messages per second. 
• Error Frames, number of error frames since the counter was cleared and the average 

number of error frames per second. 
• Error Counters, the Rx, Tx and Overrun error counters. 

Bus statistics can be cleared by clicking on the 'Clear' button. 

Bus status can be shown 'On Bus', 'Error Passive' and 'Overrun'. 
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5.4 CAN Periodic Send Features 

 

The following fields exist in the CAN Periodic Send view: 

 

Channel A select box to select which CAN Channel to send out CAN messages 
on. 

CAN Identifier A set of fields to control the CAN identifier(s) to be used in the CAN 
messages. 
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Constant Identifier The same identifier is used by every message. 

Random Identifier Identifier to use is picked by taking a random identifier from a specified 
range. 

Scan identifier Identifier to use is picked from a specified range. 

Frame Definition A set of fields to control what kind of CAN frame to send out and what 
data it should contain. 

Frame type is selected from a select box.  
Possible frame types are: 
•  CAN 
•  CAN FD 
•  ERRORFRAME 

For a classic CAN frame it's possible to select: 
•  remote request frame 
•  Single shot 

For a CAN FD frame it's possible to select: 
•  BRS - bit rate switch 
•  Single shot 

Both classic CAN and CAN FD frames can be sent out as: 

Frame data Is defined by selecting message data length and by editing the message 
raw data by entering the value of each byte. Both the message data 
length and the message raw data can be randomized. 

Transmission Interval A set of fields to control the transmission interval. 

Constant interval The same interval is used between each transmission. 

Random interval Interval to use is picked by taking a random interval from a specified 
range. 

Scan interval Interval to use is picked from a specified range. 

Number of Messages Specifies a fixed number of messages to be sent out or an unlimited 
number of messages. 

Burst Size A set of fields to control the burst size, i.e. the number of messages to 
be sent out at every sample point. 

Constant burst size The same number of messages are sent out at every sample point. 

Random burst size Burst size to use is picked by taking a random value from a specified 
range. 

Start periodic sender Click on the 'Start' button. 

Stop periodic sender Click on the 'Stop' button. 
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5.5 CAN Send Features 

 

The following fields exist in the CAN Send view: 

Channel A select box to select which CAN Channel to send out CAN messages 
on. 

CAN Identifier A set of fields to control the CAN identifier to be used in the CAN 
message. 

Frame Definition A set of fields to control what kind of CAN frame to send out and what 
data it should contain. 

Frame type is selected from a select box.  
Possible frame types are: 
•  CAN 
•  CAN FD 
•  ERRORFRAME 

For a classic CAN frame it's possible to select: 
•  remote request frame 
•  Single shot 

For a CAN FD frame it's possible to select: 
•  BRS - bit rate switch 
•  Single shot 
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Frame data Is defined by selecting message data length and by editing the message 
raw data by entering the value of each byte. The message raw data can 
be randomized by clicking on the 'Randomize Data' button. 

The message is sent out on the selected CAN Channel by clicking on the 'Send' button. 

 

5.6 CAN Trace Features 

 

Fixed Position Mode Chosen by selecting the 'Fixed Position' toggle button in the toolbar.In 
'Fixed Position Mode it is possible to expand each message row to 
display signal values. Signal values can only be displayed if a CAN 
Database’s node has been added to the measurement setup. 

Scrolling Mode Chosen by deselecting the 'Fixed Position' toggle button in the toolbar. 

The trace can be:  

Cleared  by clicking on the 'x' button in the toolbar. 

Paused  by clicking on the 'Pause' button in the toolbar. 

Filtered  by channel name by selecting a channel name from the 'Channel Filter' 
select box in the toolbar. 

Filtered by direction  by selecting 'Tx' or 'Rx' from the 'Dir Filter' select box in the toolbar. 
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6 CanKing Tools Area 

 

6.1 Log View Features 

 

The Log view displays log messages from both the CanKing application and from the CanKing 
service. 

The Log view can be:  

Cleared By clicking on the 'x' button in the toolbar. 

Paused By clicking on the 'Pause' button in the toolbar. 
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Set Log Level Possible levels are: 
•  Trace 
•  Debug 
•  Info 
•  Warn 
•  Error 
•  Critical 
•  None 

6.2 Terminal Features 

 

The Terminal view can be used to control the CanKing service using the CanKing CLI 
application. 

Enter 'ck --help' to display help for the CanKing CLI. 
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7 Status bar 

 

  

  

7.1 Status bar, Traffic gauge 
Shows bus load for each channel.  

Yellow error passive  

Red bus off'  

7.2 Status bar, Project filename 
In the Status Bar, you will find the CanKing version number, and also (if you have opened/saved) 
the Project Filename. 
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8 Closing CanKing 

 

When the CanKing application is closed, the workspaces will close since they only exist in the 
application, but the measurement setup is actually a setup of what is executing in the CanKing 
service. So when the CanKing application closes, the user needs to then decide if he wants the 
measurement setup to be kept in the service or not. 

A use case could be that you use CanKing application to configure a setup in the service, you 
start the measurement and then you close the application because you don't want to look at 
any data in real-time, but you want to keep the measurement going to create log files for you. 

So clicking ‘Yes’ will stop any running measurement and clear the setup in the service and 
clicking ‘No’ will leave any setup and state as it is. 

The checkbox will prevent this dialog from coming up every time. The selection will be saved to 
the user settings and can be configured in the Settings dialog. 
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9 Typical use case Project Trace_2ch_Virtual 

 

This sample project uses two Kvaser Virtual CAN interfaces. 

Kvaser Virtual CAN interfaces are installed when installing the Kvaser Drivers. 

By default (on Windows), there are two Virtual interfaces installed. It is possible to install more 
Virtual CAN interfaces. 

The purpose of the Virtual Interface is that it should be possible to try Kvaser Software without 
having access to physical CAN interfaces. 
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9.1 Step 1, Create new project 

 

Start CanKing and press “New Project” 

Save the project with “Save As” ( •••/File/Save As), select a nice name for your project. 
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The filename shall now be visible in the lower-right status area. 

Make sure that you are in the Measurement area, you can select it by clicking on the icon  

9.2 Step 2, Designing Measurement Setup 

 

Press “Source”, and select “CAN Channel” 
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Press on the line “Interface”, and select the Kvaser Virtual Interface “2 – Channel 1” 

Please note, the layout above depends on what type of Kvaser Interfaces you have installed and 
connected. Kvaser Virtual interfaces are normally always available and are always listed at the 
end. 

 

Set the other parameters as you like, for the moment we will use default values. 

 

Press “Create.” 
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CanKing will now add CAN 1 to the Workspace layout. 

It also added “CAN 1 – Out.” It represents the Output at CAN 1. 

Repeat this step and add the second Virtual channel. 

Please note, when adding the second channel, the first channel you added will not be available. 
It is only possible to add a specific channel once. 
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Layout when two channels have been added. 

9.3 Step 3, Designing Workspace Setup 

 

Switch to Workspace Setup, this is done by pressing the icon  

Press “Select View”, and select “CAN Trace.” 
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A trace window is now added to the Workspace. 

It is possible to add multiple Workspaces, but for the moment we will use only this one. 
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9.4 Step 3 Start/Stop Measurement 

 

By pressing the “Start Measurement” icon at the top left corner, the measurement phase will 
start. 
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The icon at the top left corner, will change to a “Stop Icon” and a circle will be animated around 
it. This indicated that CanKing has opened the interfaces and runs in Measurement Phase. 

 

Most likely, nothing will be visible in the trace window, for the moment we do not have any 
traffic on the Virtual CAN bus. 

If you have selected one of your Kvaser CAN interfaces, and it is connected to a CAN bus with 
traffic, then you can expect to see frames in the trace window. 

Stop the measurement! We must add a data source. 

9.5 Step 4 Add a Traffic Generator 
• Stop the measurement (if started) 
• Switch to Measurement Setup 
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Press “Source”, and select “Traffic Generator” 

 

  

Now you can configure your traffic generator. 

I edited: 

Name:  MyTestDataGen 

CHANNEL: CAN 2 



Kvaser CanKing User Guide   41(44) 

 Kvaser AB, Mölndal, Sweden – www.kvaser.com 

CAN IDENTIFIER: Selected “Scan Identifier” from 101 to 105 

Random data length: True 

Random message data: True 

Transmission interval: 250ms 

 

Press “Create” 

 

 

 

CanKing have now added the Traffic Generator: MyTestDataGen 

It shows in the measurement setup, with a connection to the “CAN 2 – Out” 

 

9.6 Step 5 – Explore Trace Window 
• Switch to Workspace 
• Start the measurement 
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The “Trace Window” will now show the CAN bus data. 

Please feel free to play around with the Trace controls. 

9.7 Step 6 – Close CanKing 
Important! Before closing CanKing, please remember to SAVE your project. 
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10 Quick Button Guide 
F1 

F2 

F3 

F4 

F5 

F6 

F7 

F8 

F9 Start Measurement 

F10 

F11 Toggle Full Screen Mode 

F12 Stop Measurement 

Ctrl + Zoom In 

Ctrl  - Zoom Out 

Ctrl  0 (zero) Zoom Reset 

Ctrl N New Project 

Ctrl O Open Project 

Ctrl S Save Project 

Ctrl Shift S Save Project As 

Ctrl , Settings 
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